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Alibre Design – Modeling Fundamentals  
 
Introduction 

 
Alibre Design is a parametric solid modeling system.  Parametric solid modeling involves the 
application of dimensions and other parameters to define a 2D profile, and ultimately the 3D 
shape, of a part.  These dimensions and parameters can be changed at anytime to easily 
modify designs and alter the shape of a model.   
 
Parts are comprised of one or more features.  A feature represents an individual shape and can 
either add material or remove material in a part.  Examples of features include holes, fillets, 
cuts, and revolutions.   
 
Alibre Design data consists of parts, assemblies, and drawings.  Full associativity between 
parts, assemblies, and drawings automatically applies changes made in one document across 
the entire design. 
 

 
 
Alibre Design Part Alibre Design Assembly 

 

 
 
Alibre Design Drawing 
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� You typically start a new part by first creating a sketch, which is a 2D profile of a 3D 
shape.  The sketch will subsequently be used to create a base feature, always the first 
feature you create in a part.  You can add as many additional features as necessary to 
fully define a part. 

 
� You can easily change the shape of a model by adding, deleting, editing, or reordering 

features. 
 

� You can generate 2D mechanical drawings at any time in the design process based on 
information in parts and assemblies. 

 
� You can also import parts, assemblies, and drawings from other CAD systems into 

Alibre Design.  You can modify imported parts and assemblies or you can add new 
features to them. 

 
 

Workspaces 

 
All design work in Alibre Design is done in windows called workspaces.  You can open a part, 
assembly, drawing, or bill of materials (BOM) workspace.  Each workspace is displayed in a 
separate window; however, a drawing workspace can contain multiple drawing sheets.  You can 
have as many workspaces open as needed. 
 
Opening a New Workspace 
 
 To open a new part, drawing, assembly, or BOM workspace: 
 

1 On the Home window, from the File menu, select New. 
 
2 Select Part, Assembly, Drawing, or Bill of Materials. 
 
Or 
 
Click the new Part, Assembly, Drawing, or Bill of Materials workspace icon on the 
Home window main toolbar.   
 

 
 
 
Workspace Terms  
 
Alibre Design workspaces are divided into two distinct areas.   
 

� The Design Explorer (in part and assembly workspaces) and the Drawing Explorer 
(in drawing workspaces) are located on the left side of the workspace and list all 
pertinent design information. 

� The work area is the graphics canvas in which you create all parts, assemblies and 
drawings.  Toolbars may be located above and to the right of the work area. 
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Part Workspace with default toolbars 
 
 
Model Terms 
 
The following terms are consistently used throughout the documentation and refer to geometric 
elements in a model (faces, edges, and vertices) as well as construction geometry (reference 
planes, axes, and the origin). 
 
 
 

 Edge              
 

          Vertex  
 
    
 
 
 
 
   
 
 
  

                            
   Origin     
          Face 
   

        Axis  
                    Reference Plane 
 
 

  



                                                                                                               Alibre Design – Modeling Fundamentals 
  

4 

Work Area Background Color 
 
You can change the work area background color in a part or assembly workspace.  To change 
the background color: 
 

1 In a part or assembly workspace, from the Tools menu, select Options. 
 
2 Select the Color Scheme tab in the Options dialog box. 

 
3 Choose one of the four predetermined color schemes, e.g. Dark Background 

Scheme, from the dropdown list. 
 

Or 
 

 Select a custom background color.  
 
4 Click OK to apply the setting. 
 
 

 
Multiple Views 
 
You can split the work area into as many as four different views.  You can zoom, rotate, and set 
the view mode in each view independently. 
 
To split the work area into multiple views: 
   

1 In a workspace, from the Window menu, select Split View. 
 
2 Select Horizontal, Vertical, or Both.  The Horizontal and Vertical options split the 

work area into two views.  The Both option splits the work area into four views.  
 
To select a view and make it active, click anywhere in the view border.  A red arrow appears in 
the upper right corner of the active view.  
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Named Views 
 
In part and assembly workspaces, you can use named views to control view display and 
manipulation.  You can quickly change the display to a default view and add custom views using 

the Orientations command under the View menu or by selecting the View Orientations   
tool on the View toolbar.           
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
To apply a named view to the work area, double-click a named view, or select a named view 
and then click Set. 
 
You can also add a custom view orientation by clicking Add and subsequently entering a view 
name.   
 
Default views are listed in blue, and custom views are listed in black. 
 
 
Design Explorer 
 
As previously described, each part and assembly workspace consists of the work area and the 
Design Explorer.  The Design Explorer’s primary purpose is to track and list the structure of a 
part or assembly.  However, the Design Explorer can be used to accomplish numerous tasks. 
 
Use the Design Explorer to:       
 
� Select items in the design by name. 

 
� Suppress or hide selected features and parts. 

 
� Hide planes and axes. 

 
� Temporarily roll the model or assembly back to an earlier state:   

double-click a feature or part or use the rollback bar. 
 
� Identify and change the order in which features are regenerated. 

 
� Rename features: right-click a feature and select Rename. 

 
� Delete features and parts. 

 
� Toggle the display of section views on and off. 

 
� Edit a sketch: double-click the sketch name. 
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� Track and control the display of redline markups.   
 
� Check the status of a feature or part to resolve errors. 

 
 
 
Selection Methods 
 
The majority of design tasks require that an item is selected.  For example, a reference plane or 
planar face must be selected before you can begin sketching. 
 
� Normal selecting – To select faces, edges, vertices, etc., first click the Selection tool 

 or choose Select from the View menu.  Move the cursor over an item, then click 
once to select the item.  An item will change to red as you move the cursor over it and 
will change to yellow after you select it  

 
Note: Selection highlight colors will vary depending on the work area color scheme 
used.  This documentation describes properties associated with the Dark Background 
Scheme. 

 
� Selecting Multiple Items – To select multiple items, hold the Shift key while you 

select the items.   
 
� Selecting by Dragging – In a sketch or drawing, select multiple items by dragging a 

selection rectangle around a group of items. 
 
� Using a Selection Filter – Apply a filter to make selecting a specific item type easier.  

Filter on Features, Faces, Edges, and/or Vertices.  To apply selection filter, from the 
Tools menu, expand Selection Filters and choose the appropriate filter.  You can also 
activate the Selection Filters toolbar and control filters easily with icons. 

 
� Face, Edge, and Vertex Cursors – As you move the cursor over faces, edges, and 

vertices, the cursor will change to provide a visual indication of the item type.   
 

          
Vertex Selection Edge Selection Face Selection 

 
� Modifying a Selection – Many dialog boxes require a selection or multiple selections in 

order to complete the command.  The selected item name will often populate an area in 
a dialog box.  To change the selection, either make another selection, which will override 
the previous selection, or right-click the item name in the dialog box, and choose Clear 
Selections or Remove Selected Item(s). 

 
� Advanced Selector – On occasion, other items may obscure the item you want to 

select.  Use the Advanced Selector to accurately select an item.  To use the Advanced 
Selector, move the cursor over the item and click the right-click.  The Select dialog box 
appears containing all the items in the vicinity.   Select the item you want from the list. 

 



Alibre Design – Modeling Fundamentals    
  

7 

 

 
 
Note: If available, you can also click the middle mouse button to access the Advanced 
Selector.   

 
� Selecting from the Design Explorer – Select any item in the Design Explorer by 

clicking the item name.  The associated item will change color in the work area.  Select non-
consecutive items in the Design Explorer by holding down the Ctrl key as you click.  Select 
consecutive items in the Design Explorer by holding down the Shift key as you click.   

 
 
 
Toolbars 
 
You can control toolbar visibility as well as toolbar position in a workspace.   
 
To turn toolbars on and off: 
 

1 In any open workspace, from the View menu, select Toolbars.  The Toolbars dialog box 
appears. 

2 To hide a toolbar that is currently displayed, click the checked box next to the toolbar 
name. 

3 To display a toolbar, click the empty check box next to the toolbar name.  
 
4 Click OK to apply changes. 

 
 

 
 
 
To move a toolbar between the top and right of the workspace:  
 

1 In any open workspace, from the View menu, select Toolbars.  The Toolbars dialog box 
appears. 

 
2 To move a toolbar from the top of the workspace to the right of the workspace, select 

the toolbar name and then click Right.  
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3 To move a toolbar from the right of the workspace to the top of the workspace, click the 
toolbar name and then click Top. 

 
4 Click OK to apply changes. 
 

To drag a toolbar to a different position in an area: 
 

1 Move the cursor near the vertical bar on the left side of the toolbar. 
 
2 Click and hold the mouse button and drag the toolbar to a new position within its 

respective area. 
 
 
View Manipulation 
 
You can change the perspective and orientation of the work area view by using the rotate, 
zoom, and pan tools.  These tools are available from the View toolbar and the View menu.  
 

 
 

� The Pan tool  dynamically moves the current view around the work area.  Click the 
icon and then click and drag the cursor around the work area.   

 
Note: You can also pan by holding the Shift key and the left and right mouse buttons 
down simultaneously while moving the cursor around the work area. 
 

� The Rotate tool  dynamically rotates a part or assembly around a given point.  Click 
the icon and then click and drag the cursor around the work area. 

 
Note: You can also rotate by holding the left and right mouse buttons down 
simultaneously while moving the cursor around the work area. 
 

� The Zoom Mode tool  dynamically changes the scale of the work area view.  Click 
the icon, hold the left mouse button down, and move the cursor up to zoom in, or down 
to zoom out. 

 
Note: If available, you can use the mouse wheel to dynamically zoom in and out. 
 

� The Zoom to Window tool  changes the scale of the view so that a specified region 
fills the work area.  Click the icon, click and drag a rectangle around an area with the 
cursor.  Release the mouse button when the rectangle borders the correct area. 

 

� The Zoom to Fit tool  restores the view so that the entire design is displayed in the 
work area. 

 

� The Previous View    tool reorients the work area to views that preceded the current 

view.  The Next View   tool becomes available after the Previous View tool has been 
used. 

 

� The Orthographic  tool changes the display of the work area so that parallel edges, 
faces, etc. appear as infinitely parallel. 
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� The Perspective  tool changes the display so that all parallel edges, faces, etc. 
appear to converge into one point.    

 

� The Wireframe tool  changes the display so that only the edges of the model are 
shown. 

 

� The Shaded tool  changes the display so that the faces of the model are shaded. 
 

� The View Orientations tool  stores default views (e.g. front, back, left, etc.) as well 
as custom views. 

 

� The Rotation Points tool  stores default rotation points (the origin, model’s center of 
mass and center of volume) as well as custom rotation points.   

 
 
 
 
 
Getting Help  
 
Help can be accessed numerous ways while you are using Alibre Design. 
 
� While online, you can access the Help system from any window with the Help menu or 

the F1 key. 
 
� You can also install the Help system locally off so that Help is available when you are 

working offline.  You may install Help from the CD or the Alibre support web site, 
www.alibre.com/support.  

 
� Seven help modules related to basic functionality are accessible on the Home window in 

the Welcome tab.  Click one of the seven links in the How Do I section to access these 
help modules.  

 
� To access help related to a specific dialog box, click the Help button in the dialog box. 

 
� When you mouse over an icon on a toolbar, a Tooltip will popup that identifies the 

function of the tool. 
 
� The status bar in the lower left corner of a workspace displays hints related to 

completing a command and provides a brief description of a tool or function. 
 
� While online, you can contact the Alibre Assistant from the Contacts list in the Home 

window.  You can send messages, emails, start a chat conversation, and work in a Team 
Design session in real-time to ask technical questions and resolve issues.  The Alibre 
Assistant is available from 8:00 am to 5:00 pm Central Time.    

 
� New documentation materials including tutorials will be available periodically on the 

Alibre website, www.alibre.com, in the Support section.  In order to access the 
materials, you must first sign into the web site.  Check frequently for updates.     

          


